two questions about Easy Books

Thomas Knull's Avatar

Thomas Knull

02 Jan, 2013 10:52 AM

Very much hoping you can help me with two problems:

1 Unable now to enter any new transactions on Mac (can on the iPhone or iPad)
2 Cannot figure out how to get the consolidation to work. Set the period to end 12/31/2012 and ran consolidation... with next consolidation set to 12/31/2013... seems to work, but as soon as i quit the application and restart it, it has lost the consolidation. So confused...

  1. Support Staff 1 Posted by Admin on 02 Jan, 2013 11:01 AM

    Admin's Avatar

    Hi Thomas,

    1. Does the Mac app say anything when you try to save transactions? Or is the save button greyed out?

    2. Strange, so you set the date of next consolidation as 12/31/2012 in the business settings? Then run the P&L report and check the end-date is indeed 12/31/2012 click the button and the report should update to run from 1/1/2013 to the current day.

    Are you using Easy Books for Mac from the Mac App Store? I assume so. I don't know if you've purchased any add-ons for the Mac app, you could try restoring them from the add-ons screen using the restore button.


  2. 2 Posted by Thomas on 02 Jan, 2013 04:22 PM

    Thomas's Avatar

    Hello Mathew...

    1) When I try to save transactions (no, button is not greyed out, as long
    as I have changed something that necessitates a save), it gives the error
    "Failed to Save, Transaction Could Not Be Saved". See screen shot
    attached. It also gives this same error if I try some other things. For
    example, if I open an existing sale, and select "Receive Payment" from the
    option menu, it gives that error and will not create the new transaction.
    2) Yes... I set the date of next consolidation for 12/31/2012. And The
    report showing was for 1/04/12 to 12/31/12.... (jan 4 was when i started
    using the program, no entries before then). It lets me click the
    consolidation button. One i do so, the date of next consolidation properly
    changes to 12/31/2013. But I notice that the report it is showing changes
    from 1/04/12 to 1/02/13 (present day). When I click on the tab to view
    transactions, it has properly greyed out all transactions that are in
    2012... only the one i entered for january is normal. This seems normal,
    right? However, If i then quit the program, without doing anything else...
    and relaunch the program... it is no longer this way. None of the
    transactions are greyed out any longer, and its as though no consolidation
    has been run. Attached is a screen shot taken immediately after clicking
    the Consolidate button.
    3) Correct, this was purchased from the app store. I also have nearly all
    of the add-ons (the only one I don't use is time tracker), which I have
    purchased for both the Mac and for my iPhone as well. They seem to be
    working ok (say "Installed"). I clicked the Restore button anyhow, which
    it said it did, now the Restore button is not available. However, all the
    above errors still exist.


  3. Support Staff 3 Posted by Admin on 02 Jan, 2013 11:05 PM

    Admin's Avatar

    Thanks for the screenshots Thomas, that really helps.

    I can see you're using Syncing, so I wonder if you could try this for me:

    On the Mac could you turn off syncing and then turn back on again. Choose the option to re-upload and the version on the Mac will be uploaded to replace the online copy. Your other devices should then re-sync to the new snapshot without your needing to do anything else, but give them the chance to by making sure they have network connectivity first.

    By uploading a new snapshot the problem may be fixed because the server will re-allocate a new set of unique keys for each device. I would be interested to hear whether this helps, as I did find a problem earlier which turned out to be in the new version of the iOS app. There is a bug in the Apple code which I have reported to them and I have a workaround for, but this will of course take a week or so to go through approval again. It's possible you're seeing an effect of the update on the Mac since the iOS app could have used up a unique key that it should not have been using.


  4. 4 Posted by Thomas on 02 Jan, 2013 11:29 PM

    Thomas's Avatar

    That did the trick. Turned it off, back on, chose re-upload. Re-synced
    the iPhone and iPad. I then ran the Mac app, and tried creating new
    transactions, and it worked perfectly. I then went to try to consolidate,
    and it went good. I consolidated through 12/31/12, and it did. And unlike
    before, this time it showed the date of last consolidation, as well as the
    option to "Undo Last Consolidation"... something it never showed before
    when i had tried (and confused me because I had been looking on your
    support pages about consolidation prior to trying to contact you, and saw
    something about that there... but not in my program).
    Thank you for your help. I'm very relieved.

  5. Support Staff 5 Posted by Admin on 03 Jan, 2013 10:39 AM

    Admin's Avatar

    Hi Thomas,

    That does seem to confirm my suspicions. I hope Apple approve the app update quickly. I have another similar report which I believe is the same root cause:

    I'm glad to have a workaround in place, but I don't hold out much hope for Apple responding to the bug quickly: they seem to have a more important "Do Not Disturb" bug in iOS 6 to deal with at the moment!


  6. Admin closed this discussion on 20 Feb, 2013 12:55 PM.

  7. Thomas re-opened this discussion on 07 Mar, 2013 01:26 AM

  8. 6 Posted by Thomas on 07 Mar, 2013 01:26 AM

    Thomas's Avatar

    I have printed my profit/loss sheet to give to my account... and it shows
    the totals for each account. However, he wants a list of transactions for
    each account, but I do not see a way to print a report for each account.
     Is there a way to do so?
    (p.s. just added another year to my online sync... love the app)

  9. Support Staff 7 Posted by Mark on 07 Mar, 2013 09:22 AM

    Mark's Avatar

    Yes, if you go to 'Other reports' then select transaction list, it will ask you which account you'd like, and then you can save it or print it, or even email.

    I hope that helps and than you for the compliment,


  10. 8 Posted by Thomas on 21 May, 2013 05:30 PM

    Thomas's Avatar

    I'm still not sure what to do about the invoices carrying over to two
    pages. See attached example. It does not matter whether I put all the
    info in the header, or if I put the phone number and fax number in the
    footer below. No matter how I do it, I am always getting two pages. Even
    where there is hardly any info in the invoice. Is there no way to format
    it so that its doing that?

  11. Support Staff 9 Posted by Mark on 22 May, 2013 09:37 AM

    Mark's Avatar

    Have you got the latest update? I think we have a fix for this problem.

    Thank you


  12. 10 Posted by Thomas Knull on 22 May, 2013 02:28 PM

    Thomas Knull's Avatar

    The app store shows me as being up to date.... last update was a couple days ago... 6.0.7 on iOS. On my desktop it is version 3.0. So i have just noticed the following from the desktop: If I select "Print" it prints to two pages (does not fit it on one). If I select "Save" it saves a pdf file to my computer, which fits fine on one page. Further.. when I email it to the customer, it sends a pdf that fits properly. And that is the most important part. So the only time it is wrong is if I select Print from the desktop app menu.

    Thomas Knull
    Fleetfoot Courier

  13. Support Staff 11 Posted by Mark on 23 May, 2013 05:25 PM

    Mark's Avatar

    Hi Thomas,

    This is now fixed and due to be released very soon. Thanks for letting us know about it.

  14. Mark closed this discussion on 26 May, 2013 08:19 AM.

  15. Thomas Knull re-opened this discussion on 05 Apr, 2016 06:38 PM

  16. 12 Posted by Thomas Knull on 05 Apr, 2016 06:38 PM

    Thomas Knull's Avatar

    Hello Mathew,
    I mentioned to you a few months back (can’t find that particular email thread).. about one glitch i saw.. where when i clicked the up arrow to change order of items on an invoice, the detail field got changed so both items had identical. I just had it happen, and was able to get a before and after screen shot of it. After clicking the up arrow to move the last item up one, it did so… but its detail changed to the item it was bumping down a spot. When i clicked the down arrow to return it to where it had been, the detail reverted to its correct detail.
    recreation steps:
    1) opened a sales transaction
    2) clicked the + icon to add new line
    3) entered data
    4) clicked the up arrow.

    two things of note: i saved the transaction and exited out… reentered, and was able to move it without this problem. and before doing so, i tried deselecting the text (which you can see in the photo).. to make sure that that wasn’t the issue, which didn’t change the problem.

    p.s. just had another one-year renewal for syncing. keep up the good work.

  17. Mark closed this discussion on 23 Jun, 2016 03:12 PM.

Discussions are closed to public comments.
If you need help with Easy Books please start a new discussion.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac